Resolved Bug: [1.13.1][4.5.0] Miniature Pets not working

Discussion in 'Resolved Issues' started by yesdog, Sep 24, 2018.

  1. yesdog

    yesdog New Member
    Supporter Premium Supporter

    Joined:
    Sep 14, 2018
    Messages:
    3
    Likes Received:
    0
    Enter a brief description of what is broken Miniature Pets not working

    What version of Minecraft are you using? 1.13.1

    What server jar are you using? PaperSpigot

    What is this a bug report for? MythicMobs

    What version of the plugin are you using? 4.5.0-SNAPSHOT

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    MythicMobs will not load any mobs that use miniature pets.

    java.lang.NoClassDefFoundError: com/kirelcodes/miniaturepets/api/pets/APIMobContainer

    https://gist.github.com/colinrgodsey/17196da68f2d7be6557ad7f942b2a056

    Example Configurations
    ExampleCharmander:
    Type: MPET
    MPet:
    Type: charmander
    Anchor: POLAR_BEAR
    ShowName: false
    Display: ""
     
    #1
  2. yesdog

    yesdog New Member
    Supporter Premium Supporter

    Joined:
    Sep 14, 2018
    Messages:
    3
    Likes Received:
    0
    from ash: the author of miniaturepets is redoing their API, once he's done he said he'll send me what i need to fix support
     
    #2
  3. Roger M

    Roger M Member
    Supporter Quality Assurance

    Joined:
    May 13, 2016
    Messages:
    83
    Likes Received:
    8
    MPets is confirmed to work on 1.13.2 and latest releases of MPets and MM. If you run into any issues, tag me.
     
    #3

Share This Page