Bug: Attributes not holding when updating from v4.9.1

Discussion in 'Bug Reports' started by dxultimate, Jun 28, 2020.

  1. dxultimate

    dxultimate New Member
    Premium Supporter Supporter

    Joined:
    May 13, 2019
    Messages:
    7
    Likes Received:
    1
    Enter a brief description of what is broken Attributes not holding when updating from v4.9.1

    What version of Minecraft are you using? 1.16

    What server jar are you using? Paper-2 1.16.1

    What is this a bug report for? MythicMobs

    What version of the plugin are you using? 3330

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    So this is probably way too early for something like this, and it probably being worked on as we speak, but SNAPSHOT 4.10.0 isn't loading the attributes listed in the configs that were written in v4.9.1, and is spawning in the items with vanilla attributes.

    I will try this with the newer paper builds to see if it breaks in those as well, but I figured I would leave this as a placeholder, for now as this is still very early 1.16 stages. Thanks again!

    EDIT: Some console dumps;
    https://puu.sh/G1AfJ/09422e46ae.png

    Example Configurations
    ShinyCap2:
    Id: DIAMOND_HELMET
    Data: 0
    Display: '&2The Shiny Cap''
    Enchantments:
    - DURABILITY:10
    - PROTECTION_ENVIRONMENTAL:10
    - PROTECTION_FIRE:7
    - PROTECTION_PROJECTILE:7
    - OXYGEN:5
    Attributes:
    Head:
    AttackSpeed: 0.4
    AttackDamage: 3
    Armor: 6
    Health: 10
    Options:
    Repairable: true
     
    #1
    Last edited: Jun 28, 2020

Share This Page