Incompatible Version Bug: Console error in MC Version 1.15.1

Discussion in 'Bug Reports' started by Fargus, Jan 14, 2020.

  1. Fargus

    Fargus Member

    Joined:
    Jan 5, 2018
    Messages:
    41
    Likes Received:
    4
    Enter a brief description of what is broken Console error in MC Version 1.15.1

    What version of Minecraft are you using? All of the above

    What server jar are you using? Spigot

    What is this a bug report for? MythicMobs

    What version of the plugin are you using? 4.7.2

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    [19:34:53]: [WARN] [MythicMobs] Plugin MythicMobs v4.7.2-FREE generated an exception while executing task 58
    java.lang.IllegalStateException: MythicMobDespawnEvent cannot be triggered asynchronously from another thread.
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:511) ~[minecraft_server.jar:git-Spigot-492a779-b98e2de]
    at io.lumine.xikage.mythicmobs.adapters.bukkit.BukkitWorldManager.handleMobDespawnEvent(BukkitWorldManager.java:108) ~[?:?]
    at io.lumine.xikage.mythicmobs.mobs.ActiveMob.setUnloaded(ActiveMob.java:436) ~[?:?]
    at io.lumine.xikage.mythicmobs.mobs.ActiveMob.tick(ActiveMob.java:156) ~[?:?]
    at io.lumine.xikage.mythicmobs.skills.SkillManager.runTimerSkills(SkillManager.java:328) ~[?:?]
    at io.lumine.xikage.mythicmobs.clock.MythicMobsAsyncClock.run(MythicMobsAsyncClock.java:21) ~[?:?]
    at org.bukkit.craftbukkit.v1_15_R1.scheduler.CraftTask.run(CraftTask.java:81) ~[minecraft_server.jar:git-Spigot-492a779-b98e2de]
    at org.bukkit.craftbukkit.v1_15_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:54) [minecraft_server.jar:git-Spigot-492a779-b98e2de]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_231]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_231]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_231]

    Example Configurations
    This is spamming
     
    #1
  2. jaylawl

    jaylawl Developer
    Developer Community Manager Premium Supporter Supporter Quality Assurance

    Joined:
    Sep 16, 2015
    Messages:
    1,840
    Likes Received:
    176
    mythicmobs 4.7 is not compatible with spigot 1.15
     
    #2
  3. Fargus

    Fargus Member

    Joined:
    Jan 5, 2018
    Messages:
    41
    Likes Received:
    4
    Witch version is supported? 1.14.4 ?

    The premium version of MM is for 1.15.1 ? If yes I will buy it
     
    #3
    Last edited: Jan 16, 2020
  4. jaylawl

    jaylawl Developer
    Developer Community Manager Premium Supporter Supporter Quality Assurance

    Joined:
    Sep 16, 2015
    Messages:
    1,840
    Likes Received:
    176
    4.7+ supports minecraft 1.14
    the current 4.9 dev builds (those are included in premium) support minecraft 1.15
     
    #4

Share This Page