Verified Issue Bug: Hoe's wont till dirt even when setting Ammo to False

Discussion in 'Bug Reports' started by KingCat, Sep 1, 2019.

  1. KingCat

    KingCat New Member

    Joined:
    Jul 19, 2019
    Messages:
    7
    Likes Received:
    1
    Enter a brief description of what is broken Hoe's wont till dirt even when setting Ammo to False

    What version of Minecraft are you using? 1.14

    What server jar are you using? Spigot

    What is this a bug report for? Artifacts

    What version of the plugin are you using? 4.7

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    Basically when I am trying to create a hoe with a display name, the hoe will no longer use the right click feature. I have tried giving it a skill that, upon right clicking, will change dirt to tilled dirt, but still wouldn't work. I noticed in console after using lvl 4 debug that the hoe was actually trying to execute an Ammo Skill, which I didn't have. After I added a part to the code that disabled Ammo abilities, the console still kept telling me that the hoe was trying to use Ammo abilities.

    Example Configurations
    Item:

    testhoe:
    Id: DIAMOND_HOE
    Display: '&8&l[ &cTEST Harvester &8&l]'
    Ammo:
    Enabled: FALSE
    Skills:
    - skill{s=FarmLand} @Target ~onRightClick

    Skill:

    FarmLand:
    TargetConditions:
    - blocktype DIRT,GRASS_BLOCK true
    Skills:
    - setblock{m=FARMLAND;md=0}

    Debug Information:

    01.09 13:49:54 [Server] INFO [MythicMobs] ---- Executing Ammo skill
    01.09 13:49:55 [Server] INFO [MythicMobs] ---- Executing Ammo skill
     
    #1
  2. iTzCascadexX

    iTzCascadexX Member
    Premium Supporter Supporter Moderator Quality Assurance

    Joined:
    Nov 2, 2015
    Messages:
    104
    Likes Received:
    15
    Can replicate. It's to do with the Display tag, not Ammo.
    Code:
    TestHoe:
      Id: Diamond_Hoe
      Display: "Test"
    The above causes the issue to happen.
    If you try to replicate with another plugin or nametag, it'll till still.
     
    #2

Share This Page