Verified Issue Bug: Imported Items can't be given anymore

Discussion in 'Bug Reports' started by Elric, Mar 22, 2020.

  1. Elric

    Elric New Member

    Joined:
    Nov 10, 2017
    Messages:
    8
    Likes Received:
    3
    Enter a brief description of what is broken Imported Items can't be given anymore

    What version of Minecraft are you using? 1.14

    What server jar are you using? PaperSpigot

    What is this a bug report for? MythicMobs

    What version of the plugin are you using? 4.9.0

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    Hello,
    I was using premium dev versions last months (I had bought 2 months premium), and I had no problem with this. But since a few days ago (so it must be broken since a few updates before official 4.9.0) my imported items (mob eggs and heads) don't work anymore. When I try to get one using /mm items get, it tells me "Could not get item: item is improperly configured and returned null."
    I tried doing /mm items import with another mob head for test purposes, but it returned the same error : all my imported items don't work anymore (so again, they were working a few weeks ago).
    I can get not-imported items fine.

    PS : If you could roll out an update free for everybody with this fix, it would help me a lot... already bought 2 months of premium (10$) and I can't really afford more just for 1 bug fix, even if that's a functionnality I use a lot

    Thanks

    Example Configurations
    Dimanche2:
    ItemStack:
    ==: org.bukkit.inventory.ItemStack
    v: 2227
    type: PLAYER_HEAD
    meta:
    ==: ItemMeta
    meta-type: SKULL
    display-name: Clay Pot
    internal: H4sIAAAAAAAAAE2PwW6CQBRFX5s0oaSf0S3JDAiFRRe0WBwiQ1FEmB3CGBkHaxQU+K5+YFl2eXPOWVwVQIWX9bGT8vvys68lV+CRVPBqlRiVumNp2EaVNpvhQrMNHWuWg4s9NktuI0MFdYrO/NLW/PoMSsv7trvwqwoADwo8pYXsOPzyIUAsO6AqC2Q5EGvayRrJiIjzGzmlw+6TWKSZ+MK1loPzzzXbYmvK3AgO7BR3uyZFS2Ml+WKFy2Zzo+IgqHDvdAx1to3N0CN9nlQNS8ohFMdZ5Mf3PIn7yJsbVJ8PzCNj6AeSiXiMvA8Zjm5Pmw2mYyqonhvM/xK0Dpx9ht6nB/AHTUWhGBwBAAA=
     
    #1
    BadWolfMC, monzter and frankyboi like this.
  2. Duckling

    Duckling New Member

    Joined:
    Jun 23, 2016
    Messages:
    7
    Likes Received:
    5
    Similar experience. Even with items like Wooden Swords--the issue is not linked to it being a playerHead, or anything like that.
    For Example:
    Weapon1:
    ItemStack:
    ==: org.bukkit.inventory.ItemStack
    v: 2230
    type: WOODEN_SWORD
    meta:
    ==: ItemMeta
    meta-type: UNSPECIFIC
    display-name: §5Silly Sword
    enchants:
    KNOCKBACK: 1
    DAMAGE_ALL: 1​
     
    #2
    Elric likes this.
  3. frankyboi

    frankyboi New Member

    Joined:
    Feb 23, 2020
    Messages:
    1
    Likes Received:
    1
    same case here i did mm i import and the items do import but i cant get them back using mm...it says ''item is improperly configured and returned null." before the official 4.9.0 premium update it was working fine...for example this is what i imported but cant get it using /mm i get
    maxboots:
    ItemStack:
    ==: org.bukkit.inventory.ItemStack
    v: 2227
    type: DIAMOND_BOOTS
    meta:
    ==: ItemMeta
    meta-type: UNSPECIFIC
    enchants:
    DEPTH_STRIDER: 3
    PROTECTION_ENVIRONMENTAL: 4
    MENDING: 1
    THORNS: 3
    DURABILITY: 3
     
    #3
    Elric likes this.
  4. Kuba4ful

    Kuba4ful New Member

    Joined:
    Mar 22, 2020
    Messages:
    1
    Likes Received:
    0
    I have the same issue, and since no one posted the error message before, I guess I will be the first one to do it.

    org.bukkit.command.CommandException: Unhandled exception executing command 'mm' in plugin MythicMobs v4.9.0-3255
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:47) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:159) ~[patched_1.15.2.jar:git-Paper-143]
    at org.bukkit.craftbukkit.v1_15_R1.CraftServer.dispatchCommand(CraftServer.java:752) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.PlayerConnection.handleCommand(PlayerConnection.java:1825) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.PlayerConnection.a(PlayerConnection.java:1633) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.PacketPlayInChat.a(PacketPlayInChat.java:47) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.PacketPlayInChat.a(PacketPlayInChat.java:5) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.PlayerConnectionUtils.lambda$ensureMainThread$0(PlayerConnectionUtils.java:23) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.TickTask.run(SourceFile:18) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.executeTask(IAsyncTaskHandler.java:136) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.IAsyncTaskHandlerReentrant.executeTask(SourceFile:23) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.executeNext(IAsyncTaskHandler.java:109) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.MinecraftServer.ba(MinecraftServer.java:1038) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.MinecraftServer.executeNext(MinecraftServer.java:1031) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.awaitTasks(IAsyncTaskHandler.java:119) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.MinecraftServer.sleepForTick(MinecraftServer.java:1015) ~[patched_1.15.2.jar:git-Paper-143]
    at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:938) ~[patched_1.15.2.jar:git-Paper-143]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_181]
    Caused by: java.lang.NullPointerException
    at io.lumine.xikage.mythicmobs.items.MythicItem.generateItemStack(MythicItem.java:437) ~[?:?]
    at io.lumine.xikage.mythicmobs.commands.items.GiveCommand.onCommand(GiveCommand.java:86) ~[?:?]
    at io.lumine.xikage.mythicmobs.utils.commands.Command.onCommand(Command.java:68) ~[?:?]
    at io.lumine.xikage.mythicmobs.utils.commands.Command.onCommand(Command.java:59) ~[?:?]
    at io.lumine.xikage.mythicmobs.utils.commands.Command.onCommand(Command.java:65) ~[?:?]
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:45) ~[patched_1.15.2.jar:git-Paper-143]
    ... 17 more
     
    #4
  5. MinatoAqua233

    MinatoAqua233 New Member
    Premium Supporter Supporter

    Joined:
    Feb 7, 2020
    Messages:
    3
    Likes Received:
    1
    4.9.1 1.15.2 also have this problem
     
    #5
    Elric likes this.
  6. Tankdest22

    Tankdest22 Active Member
    Supporter Moderator Quality Assurance

    Joined:
    Jul 20, 2015
    Messages:
    218
    Likes Received:
    41
    I can agree this is a problem. I've had this issue myself.
     
    #6
  7. zEricz

    zEricz New Member
    Premium Supporter Supporter

    Joined:
    Feb 9, 2020
    Messages:
    1
    Likes Received:
    0
    Same! playing on 1.15.2, both MythicMobs and MMOItems last updated dev version installed
     
    #7
  8. Raigna

    Raigna New Member
    Supporter

    Joined:
    Aug 6, 2017
    Messages:
    6
    Likes Received:
    0
    yep just came on to report this too lol
     
    #8
  9. YeXiaoLu

    YeXiaoLu New Member
    Premium Supporter Supporter

    Joined:
    Mar 8, 2020
    Messages:
    7
    Likes Received:
    0
    I also have this problem. I hope the author will fix it as soon as possible.
     
    #9
  10. YeXiaoLu

    YeXiaoLu New Member
    Premium Supporter Supporter

    Joined:
    Mar 8, 2020
    Messages:
    7
    Likes Received:
    0
    I also have this problem. I hope the author will fix it as soon as possible.
    I don't want to spend money on bad plug-ins.
     
    #10
  11. Baymin

    Baymin New Member
    Premium Supporter Supporter

    Joined:
    Apr 9, 2019
    Messages:
    13
    Likes Received:
    0
    SAME.
    And when mobs dead,it will not drop anything of item folder.
    I think it is the same problem of item part.
     
    #11
  12. Elric

    Elric New Member

    Joined:
    Nov 10, 2017
    Messages:
    8
    Likes Received:
    3
    I hope they will release a free version soon... I know they need money but it's a shame to lock major bug fixes behind a paywall... I have no problem with small ones or with new features being premium only but here we have some major features not working at all
     
    #12
  13. Baymin

    Baymin New Member
    Premium Supporter Supporter

    Joined:
    Apr 9, 2019
    Messages:
    13
    Likes Received:
    0
    I dont care money..
    just fix them,and my server work it fine.
    And I will fill better.
    But now premium version has no solution till today.
    I dont know how long we should wait
     
    #13
  14. Aura

    Aura New Member

    Joined:
    Today
    Messages:
    1
    Likes Received:
    0
    I have the same problem right now. Just bought the plugin and i'm not able to set up my server due to this issue. Please fix this, it's the main thing we need to mess up with this plugin or it's actually useless
     
    #14
  15. Joshin

    Joshin Community Manager
    Community Manager Premium Supporter Supporter

    Joined:
    Apr 7, 2018
    Messages:
    62
    Likes Received:
    4
    Known issue, it'll be fixed and or a replacement will be done when possible. Keep in mind the import command isn't necessary and items can still be made manually. It's not the end of the world. Hang tight. Working on it asap.
     
    #15

Share This Page