Resolved Bug: Projectile mechanic not working on 1.13.1

Discussion in 'Bug Reports' started by Robotnikman, Sep 12, 2018.

  1. Robotnikman

    Robotnikman Member
    Supporter

    Joined:
    Mar 30, 2017
    Messages:
    82
    Likes Received:
    14
    Enter a brief description of what is broken Projectile mechanic not working on 1.13.1

    What version of Minecraft are you using? 1.13.1

    What server jar are you using? Spigot

    What is this a bug report for? MythicMobs

    What version of the plugin are you using? Build 2528

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    The projectile mechanic doesnt seem to be working. In the example configuration I posted, it plays the sound but doesnt fire a projectile.

    Did not see any errors mentioning the skills or mob in the server log

    Example Configurations
    https://pastebin.com/q1QN2XHW
     
    #1
    Last edited: Sep 18, 2018
    xlsalvoxl likes this.
  2. xikage

    xikage Administrator
    Administrator Developer Supporter

    Joined:
    Jul 18, 2015
    Messages:
    616
    Likes Received:
    211
    The hastebin appears to be empty for me?
     
    #2
  3. Robotnikman

    Robotnikman Member
    Supporter

    Joined:
    Mar 30, 2017
    Messages:
    82
    Likes Received:
    14
    #3
  4. Robotnikman

    Robotnikman Member
    Supporter

    Joined:
    Mar 30, 2017
    Messages:
    82
    Likes Received:
    14
    tried on a server with no plugins other than mythicmobs too to make sure it wasnt a plugin conflict, and it still was not working
     
    #4
  5. Robotnikman

    Robotnikman Member
    Supporter

    Joined:
    Mar 30, 2017
    Messages:
    82
    Likes Received:
    14
    Tested with latest premium build and still no luck with it working
     
    #5
  6. Darkitect

    Darkitect Member
    Supporter Premium Supporter Quality Assurance

    Joined:
    Mar 20, 2017
    Messages:
    131
    Likes Received:
    10
    A fix that worked for me was renaming the variables to lower case. Ex. Instead of onHit, use onhit. Also spell out all of the abbreviated ones. It's a weird fix, for sure, but it worked for me.
     
    #6
    xlsalvoxl and Robotnikman like this.
  7. Robotnikman

    Robotnikman Member
    Supporter

    Joined:
    Mar 30, 2017
    Messages:
    82
    Likes Received:
    14
    Oh damn that actually works, thanks!
     
    #7
    Darkitect likes this.
  8. xlsalvoxl

    xlsalvoxl Member

    Joined:
    Jan 9, 2017
    Messages:
    62
    Likes Received:
    7
    This is very odd. It would take days for me to fix all of my proectiles skills, so i'm still hoping on a fix :/
     
    #8
  9. Darkitect

    Darkitect Member
    Supporter Premium Supporter Quality Assurance

    Joined:
    Mar 20, 2017
    Messages:
    131
    Likes Received:
    10
    If you wrote all of your skills the same way, you could Find & Replace. I'm in the same boat as you, honestly, I just don't have the luxury of waiting for the fix, so I'll trudge on with the workaround. When it gets fixed, the workaround should still work anyway, so that's a plus.
     
    #9
    xlsalvoxl likes this.
  10. Robotnikman

    Robotnikman Member
    Supporter

    Joined:
    Mar 30, 2017
    Messages:
    82
    Likes Received:
    14
    Has anyone else noticed the HitNonPlayers option not working?
     
    #10
  11. Darkitect

    Darkitect Member
    Supporter Premium Supporter Quality Assurance

    Joined:
    Mar 20, 2017
    Messages:
    131
    Likes Received:
    10
    Did you try it all lowercase?
     
    #11
  12. Robotnikman

    Robotnikman Member
    Supporter

    Joined:
    Mar 30, 2017
    Messages:
    82
    Likes Received:
    14
    Looks like its more like the onEnd option which isnt working. The projectile explodes when it hits a mob or player, but not when it hits a block. tried all lowercase but no luck
     
    #12
  13. Darkitect

    Darkitect Member
    Supporter Premium Supporter Quality Assurance

    Joined:
    Mar 20, 2017
    Messages:
    131
    Likes Received:
    10
    Odd, onend works fine for me. Can you post an updated config? Also, stopatblock isn't working at all. I hear it's being pushed in the next build though.
     
    #13
  14. Robotnikman

    Robotnikman Member
    Supporter

    Joined:
    Mar 30, 2017
    Messages:
    82
    Likes Received:
    14
    Here they are
    https://pastebin.com/EbKagzYE
     
    #14
  15. Darkitect

    Darkitect Member
    Supporter Premium Supporter Quality Assurance

    Joined:
    Mar 20, 2017
    Messages:
    131
    Likes Received:
    10
    Looks fine to me. If it's stopatblock you're having trouble with, get in line lol
     
    #15

Share This Page