Is the newest version compatible for 1.7?

Discussion in 'Community Support' started by mattsansung, Apr 10, 2020.

  1. mattsansung

    mattsansung New Member

    Joined:
    Apr 10, 2020
    Messages:
    1
    Likes Received:
    0
    Hey, I am building a server with my friends and want to use MythicMobs. Just wonder is the newest version working on 1.7.10? or should I find a older version that support 1.7.10? Thanks, I searched online and still confused.
     
    #1

Share This Page