Installation Guide

Installing MMOCore v1.0.6+

MMOCore can be installed by drag & dropping the downloaded jar in your server plugin folder. When using MMOCore with other plugins, there might be specific instructions you need to follow to make MMOCore fully utilize its compatibility potential.

MMOITEMS AND MMOCORE BOTH REQUIRE MMOLIB TO WORK, FOUND ON SPIGOT

When using MMOCore with MMOItems

You must NOT install the Mana & Stamina MMOItems addon when using MMOCore. MMOCore adds many new item stats to MMOItems (more info here). You need to add a few lines to your MMOItems language files in order to make MMOCore 100% hook onto MMOItems. Add the following lines to your /MMOItems/language/stats.yml:

required-intelligence: '&eRequires # Intelligence'
required-strength: '&eRequires # Strength'
required-dexterity: '&eRequires # Dexterity'

max-stamina: '&7■ Max Stamina: &f<plus>#'
stamina-regeneration: '&7■ Stamina Regeneration: &f<plus>#%'
mana-regeneration: '&7■ Mana Regeneration: &f<plus>#%'
skill-cooldown-reduction: '&7■ Skill Cooldown Reduction: &f<plus>#%'
additional-experience: '&7■ Additional Experience: &f<plus>#%'

And then, these lines wherever you want in your MMOItems item lore format language file.

- '#required-intelligence#'
- '#required-strength#'
- '#required-dexterity#'
...
- '#mana-regeneration#'
- '#max-stamina#'
- '#stamina-regeneration#'
- '#skill-cooldown-reduction#'
- '#additional-experience#'

Last not but least, add this to your /MMOItems/language/messages.yml. Don't forget to use /mi reload afterwards.

not-enough-attribute: 'You do not have enough #attribute#.'

install.txt · Last modified: 2020/06/30 21:13 (external edit)